Bug reports

Posted 5 months, 25 days ago (Edited 3 months, 17 days ago) by circlejourney

A brand new bug report thread - report your bugs here! After several months of missing forum posts because I wasn't getting notifications, I figured I'd create this. Check below to see if your bug is described and try the fixes (if applicable). If that doesn't resolve the issue, then feel free to post a bug report below and I can give you personalised help! This can also help me with identifying and fixing bugs.


Bug report form

  • Operating system and browser:
  • Description of the bug:
  • Link to code that made the bug appear (if available):
  • Screen captures (if available):

Common bugs and how to fix them

Stuck on loading screen

Description: You're stuck on the loading screen with the spinny wheel. The load screen doesn't disappear. This can happen for several reasons:

  • Your browser, adblocker or VPN is blocking JavaScript on the page, preventing the site from functioning.
  • The browser is storing a cached (outdated) version of the code (possibly because I forgot to do proper cache busting, my bad), and mismatches in code files are causing errors.
  • Your custom code is causing Ace Editor to crash (e.g. having HTML tags inside an HTML comment confuses Ace Editor's code parser). I intend to change how this works in a future update.

Fix: To isolate the cause, check if the site loads fine in incognito/private browsing. If it is also broken in incognito, it is probably an issue with your browser, firewall or VPN blocking JavaScript: see if turning that off makes it load. If it's OK in incognito, and you have an adblocker extension, turn that off and see if that fixes it.

If you're sure the above things are not the cause, go to the code editor and hit Ctrl+Shift+R or Cmd+Shift+R. This will force the browser to download any new code files to replace cached versions.

If the problem still persists and you're sure the code is causing the problem, click the hard reset link on the loading screen, which should download your code into files and clear the code panels.

CSS that works on Toyhouse is broken on code editor

Description: After pasting CSS from Toyhouse into the code editor's CSS area, there are no visible changes in the preview, or it doesn't show up as expected. This is almost always because the CSS code is trying to import a stylesheet from a private Toyhouse URL that this code editor can't see. Check for a line that looks like @import 'some/characters/here'.

Fix: Toyhouse import rules are intentionally designed to prevent theft of CSS sheets. One workaround is to fetch the CSS from the TH profile's page source, but please do not do this without permission from the creator of the CSS.

HTML that works on Toyhouse is broken on code editor

Description: The theme looks fine on Toyhouse but on the code editor it "explodes" and things are in the wrong places. This usually happens because of missing closing tags (e.g. a li doesn't have a matching /li). Toyhouse applies some back-end processing to your code after you post it and automatically fixes missing end tags, but my code editor doesn't have that functionality.

Fix: Look for missing closing tags. Some of Ace editor's tools can be useful for that—clicking the little down arrow next to a start tag will cause the entire element to collapse, if you have properly closed it. If Ace can't find a matching closing tag, the element will fail to collapse.

HTML that works on code editor is broken on Toyhouse

Description: The code looks and interacts just fine on the editor, but on Toyhouse, certain elements look broken (usually split up in weird ways), or interactive elements don't function as expected when clicked. This happens because Toyhouse applies some back-end processing to your code after you post it (presumably related to the HTML/CSS blacklist). It has some particularities like not liking div tags inside a tags, and only supporting interactivity with a and button tags.

Fix: Check if you have any div tags inside a tags or are trying to use a div tag as an interactive element (these 2 situations are the most common). Generally, check if you have any block elements (like div) inside inline elements (like a or span).

Cursor is visually displaced from actual typing input

Description: Your cursor is one place, but when you type, the text appears somewhere else. Sometimes mouse interactions are also displaced. This is a visual glitch caused by Ace Editor's rendering, usually occurring when the editor is resized.

Fix: Refreshing the page will usually fix this.

Import widget says that import is not allowed (even after adding "allow-thcj-import" line)

Description: Even after adding the "allow-thcj-import" line, attempting to import the code from Toyhouse leads to the same error message stating that import is not authorised. Usually this is caused by a content warning modal that prevents the code editor from "seeing" the actual profile code. The TH Editor behaves like its own user and is unfortunately unable to "click to reveal the profile" at present.

Fix: Removing the content warning modal is the only way to fix this.

No select/cut/copy/paste functionality on mobile device

Description: Mobile context menu doesn't give you the option to copy, cut or paste text. In some cases, it will not even let you highlight text. Normally, cut/paste is handled by your device. However, many mobile devices don't play nice with Ace Editor because of their custom text input solution.

Fix: There is no known fix besides using a different device, my apologies. I will have to look into Ace docs to see if there is a workaround for this.

mintymichi
  • Operating system and browser: Windows 10 + Chrome
  • Description of the bug: Copying 3 or more lines of code past line 100 freezes the site. When I try to refresh the site, I get a popup telling me the page is unresponsive. If I exit the site via popup, it gives me error code: RESULT_CODE_HUNG.
    I tried deleting my cache and cookies multiple times and then loading in my saved code to a clean HTML box but the same thing happens.
    Occasionally, it will even freeze if I copy 3+ lines (sometimes less) before line 100, but it only happens if I have 2 tabs of the site open: 1 tab with the 1st frozen site, and the 2nd tab with the site freshly opened and then trying to copy something. Other times, it has a chance happening when trying to use the site with the loaded code after deleting cache/cookies.
    Thank you so much for this useful site and I hope you can help me with this very specific bug :,)) !!
  • Link to code that made the bug appear : rainandhail's f2u code // my slightly modified version of code I was loading into the site